re = /(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)/
str = 'Yii::t(\'backend\',\'My Profile\')
Yii::t(\'backend\',\'Log Out\')
does not match these:
Yii::t("backend", "Search...")
Yii::t("backend", \'Sounds\')
but matches these:
Yii::t("backend","Search...")
Yii::t("backend",\'Sounds\')
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end