using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Yii::t\(\s*)(\'|\"")(.*?)(\'|\"")\,\s*(\'|\"")(.*?)(\'|\"")\)";
string input = @"Yii::t('backend','My Profile')
Yii::t('backend','Log Out')
does not match these:
Yii::t(""backend"", ""Search..."")
Yii::t(""backend"", 'Sounds')
but matches these:
Yii::t(""backend"",""Search..."")
Yii::t(""backend"",'Sounds')
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}