$re = '`(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)`';
$str = 'Yii::t(\'backend\',\'My Profile\')
Yii::t(\'backend\',\'Log Out\')
does not match these:
Yii::t("backend", "Search...")
Yii::t("backend", \'Sounds\')
but matches these:
Yii::t("backend","Search...")
Yii::t("backend",\'Sounds\')
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);