// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)"#).unwrap();
let string = "Yii::t('backend','My Profile')
Yii::t('backend','Log Out')
does not match these:
Yii::t(\"backend\", \"Search...\")
Yii::t(\"backend\", 'Sounds')
but matches these:
Yii::t(\"backend\",\"Search...\")
Yii::t(\"backend\",'Sounds')
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}