package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Yii::t\(\s*)(\'|\")(.*?)(\'|\")\,\s*(\'|\")(.*?)(\'|\")\)`)
var str = `Yii::t('backend','My Profile')
Yii::t('backend','Log Out')
does not match these:
Yii::t("backend", "Search...")
Yii::t("backend", 'Sounds')
but matches these:
Yii::t("backend","Search...")
Yii::t("backend",'Sounds')
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}