using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<Action(?![^>]*?is=)";
string input = @"<Action is=""tertiary"" onClick={onClose} className=""mx-2"">
Cancel
</Action>
<Action
is=""primary""
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action onClick={onClose} className=""mx-2"">
Cancel
</Action>
<Action
color=""red""
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action
onClick={handleSave}
color=""red""
>
Save
</Action>
<Action is=""tertiary"" onClick={onClose} color=""white"" className=""mx-2"">
Cancel
</Action>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}