$re = '/<Action(?![^>]*?is=)/m';
$str = '<Action is="tertiary" onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
is="primary"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
color="red"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action
onClick={handleSave}
color="red"
>
Save
</Action>
<Action is="tertiary" onClick={onClose} color="white" className="mx-2">
Cancel
</Action>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);