import re
regex = re.compile(r"<Action(?![^>]*?is=)", flags=re.MULTILINE)
test_str = ("<Action is=\"tertiary\" onClick={onClose} className=\"mx-2\">\n"
" Cancel\n"
"</Action>\n"
"<Action\n"
" is=\"primary\"\n"
" disabled={!allRequiredFieldsPresent}\n"
" onClick={handleSave}\n"
">\n"
" Save\n"
"</Action>\n"
"<Action onClick={onClose} className=\"mx-2\">\n"
" Cancel\n"
"</Action>\n"
"<Action\n"
" color=\"red\"\n"
" disabled={!allRequiredFieldsPresent}\n"
" onClick={handleSave}\n"
">\n"
" Save\n"
"</Action>\n"
"<Action\n"
" onClick={handleSave}\n"
" color=\"red\"\n"
">\n"
" Save\n"
"</Action>\n"
"<Action is=\"tertiary\" onClick={onClose} color=\"white\" className=\"mx-2\">\n"
" Cancel\n"
"</Action>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")