import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Action(?![^>]*?is=)";
final String string = "<Action is=\"tertiary\" onClick={onClose} className=\"mx-2\">\n"
+ " Cancel\n"
+ "</Action>\n"
+ "<Action\n"
+ " is=\"primary\"\n"
+ " disabled={!allRequiredFieldsPresent}\n"
+ " onClick={handleSave}\n"
+ ">\n"
+ " Save\n"
+ "</Action>\n"
+ "<Action onClick={onClose} className=\"mx-2\">\n"
+ " Cancel\n"
+ "</Action>\n"
+ "<Action\n"
+ " color=\"red\"\n"
+ " disabled={!allRequiredFieldsPresent}\n"
+ " onClick={handleSave}\n"
+ ">\n"
+ " Save\n"
+ "</Action>\n"
+ "<Action\n"
+ " onClick={handleSave}\n"
+ " color=\"red\"\n"
+ ">\n"
+ " Save\n"
+ "</Action>\n"
+ "<Action is=\"tertiary\" onClick={onClose} color=\"white\" className=\"mx-2\">\n"
+ " Cancel\n"
+ "</Action>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}