const regex = /<Action(?![^>]*?is=)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Action(?![^>]*?is=)', 'gm')
const str = `<Action is="tertiary" onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
is="primary"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
color="red"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action
onClick={handleSave}
color="red"
>
Save
</Action>
<Action is="tertiary" onClick={onClose} color="white" className="mx-2">
Cancel
</Action>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}