use strict;
my $str = '<Action is="tertiary" onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
is="primary"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
color="red"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action
onClick={handleSave}
color="red"
>
Save
</Action>
<Action is="tertiary" onClick={onClose} color="white" className="mx-2">
Cancel
</Action>';
my $regex = qr/<Action(?![^>]*?is=)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}