import Foundation
let pattern = #"<Action(?![^>]*?is=)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<Action is="tertiary" onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
is="primary"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action onClick={onClose} className="mx-2">
Cancel
</Action>
<Action
color="red"
disabled={!allRequiredFieldsPresent}
onClick={handleSave}
>
Save
</Action>
<Action
onClick={handleSave}
color="red"
>
Save
</Action>
<Action is="tertiary" onClick={onClose} color="white" className="mx-2">
Cancel
</Action>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)