#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$"
Local $sString = "test@test.com;sample@google.com;dsdsd@dsd.sd" & @CRLF & _
"te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com" & @CRLF & _
"test@test.com;sample@google.com dsdsd@dsd.sd" & @CRLF & _
"test@test.com" & @CRLF & _
"test@test.com;" & @CRLF & _
"" & @CRLF & _
"test@test.com; test@Tes.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")