const regex = /(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!.*;$)^([-\\w]+?@\\w+\\.\\w+(?:\\s*;\\s*)?)+$', 'gm')
const str = `test@test.com;sample@google.com;dsdsd@dsd.sd
te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com
test@test.com;sample@google.com dsdsd@dsd.sd
test@test.com
test@test.com;
test@test.com; test@Tes.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}