$re = '/(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$/m';
$str = 'test@test.com;sample@google.com;dsdsd@dsd.sd
te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com
test@test.com;sample@google.com dsdsd@dsd.sd
test@test.com
test@test.com;
test@test.com; test@Tes.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);