re = /(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$/m
str = 'test@test.com;sample@google.com;dsdsd@dsd.sd
te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com
test@test.com;sample@google.com dsdsd@dsd.sd
test@test.com
test@test.com;
test@test.com; test@Tes.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end