import Foundation
let pattern = #"(?!.*;$)^([-\w]+?@\w+\.\w+(?:\s*;\s*)?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test@test.com;sample@google.com;dsdsd@dsd.sd
te-st@test.com;sample@google.com ;dsdsd@dsd.sd;hhiu@oisx.com
test@test.com;sample@google.com dsdsd@dsd.sd
test@test.com
test@test.com;
test@test.com; test@Tes.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)