#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)\s*:\s*([\w\[\], \| \^\w]+?)(?:(, optional)?)$"
Local $sString = "a: int" & @CRLF & _
"" & @CRLF & _
"a: Dict[str, Any]" & @CRLF & _
"" & @CRLF & _
"a: str | any" & @CRLF & _
"" & @CRLF & _
"a: int, optional" & @CRLF & _
"" & @CRLF & _
"a: str | any, optional"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")