const regex = new RegExp('(\\w+)\\s*:\\s*([\\w\\[\\], \\| \\^\\w]+?)(?:(, optional)?)$', 'gm')
const str = `a: int
a: Dict[str, Any]
a: str | any
a: int, optional
a: str | any, optional`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}