import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\s*:\\s*([\\w\\[\\], \\| \\^\\w]+?)(?:(, optional)?)$";
final String string = "a: int\n\n"
+ "a: Dict[str, Any]\n\n"
+ "a: str | any\n\n"
+ "a: int, optional\n\n"
+ "a: str | any, optional";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}