re = /(\w+)\s*:\s*([\w\[\], \| \^\w]+?)(?:(, optional)?)$/m
str = 'a: int
a: Dict[str, Any]
a: str | any
a: int, optional
a: str | any, optional'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end