package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w+)\s*:\s*([\w\[\], \| \^\w]+?)(?:(, optional)?)$`)
var str = `a: int
a: Dict[str, Any]
a: str | any
a: int, optional
a: str | any, optional`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}