$re = '/(\w+)\s*:\s*([\w\[\], \| \^\w]+?)(?:(, optional)?)$/m';
$str = 'a: int
a: Dict[str, Any]
a: str | any
a: int, optional
a: str | any, optional';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);