using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*:\s*([\w\[\], \| \^\w]+?)(?:(, optional)?)$";
string input = @"a: int
a: Dict[str, Any]
a: str | any
a: int, optional
a: str | any, optional";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}