import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Filter:(?:\\w+=[^;]*;)*$";
final String string = "Filter:Class=RBSG_Root_Base;\n"
+ "Filter:Class=Logfile_Base;\n"
+ "Filter:Class=Logfile_Sendmail;\n"
+ "Filter:Class=Daemon_Notice;\n"
+ "Filter:Class=Logfile_Syslogd;msg=re:'syslogd: restart';\n"
+ "Filter:Class=Logfile_Cron;msg=re:'CMD';\n"
+ "Filter:Class=Logfile_Cron;msg=re:'STARTUP';\n"
+ "Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:'support';\n"
+ "Filter:ClassAppLog;sub_sourceMTRMonmsg=re:'su;dnsdjs;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}