$re = '/^Filter:(?:\w+=[^;]*;)*$/m';
$str = 'Filter:Class=RBSG_Root_Base;
Filter:Class=Logfile_Base;
Filter:Class=Logfile_Sendmail;
Filter:Class=Daemon_Notice;
Filter:Class=Logfile_Syslogd;msg=re:\'syslogd: restart\';
Filter:Class=Logfile_Cron;msg=re:\'CMD\';
Filter:Class=Logfile_Cron;msg=re:\'STARTUP\';
Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:\'support\';
Filter:ClassAppLog;sub_sourceMTRMonmsg=re:\'su;dnsdjs;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);