use strict;
my $str = 'Filter:Class=RBSG_Root_Base;
Filter:Class=Logfile_Base;
Filter:Class=Logfile_Sendmail;
Filter:Class=Daemon_Notice;
Filter:Class=Logfile_Syslogd;msg=re:\'syslogd: restart\';
Filter:Class=Logfile_Cron;msg=re:\'CMD\';
Filter:Class=Logfile_Cron;msg=re:\'STARTUP\';
Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:\'support\';
Filter:ClassAppLog;sub_sourceMTRMonmsg=re:\'su;dnsdjs;';
my $regex = qr/^Filter:(?:\w+=[^;]*;)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}