const regex = /^Filter:(?:\w+=[^;]*;)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Filter:(?:\\w+=[^;]*;)*$', 'gm')
const str = `Filter:Class=RBSG_Root_Base;
Filter:Class=Logfile_Base;
Filter:Class=Logfile_Sendmail;
Filter:Class=Daemon_Notice;
Filter:Class=Logfile_Syslogd;msg=re:'syslogd: restart';
Filter:Class=Logfile_Cron;msg=re:'CMD';
Filter:Class=Logfile_Cron;msg=re:'STARTUP';
Filter:Class=AppLog;sub_source=MTResourceMonitor;msg=re:'support';
Filter:ClassAppLog;sub_sourceMTRMonmsg=re:'su;dnsdjs;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}