using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$";
string input = @"3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}