re = /^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$/m
str = '3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end