const regex = new RegExp('^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$', 'gm')
const str = `3OMYJF5V11MJL,3OMYJF5V11MOP
3OMYJF,3OMYJim,3OMYJF090`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}