import re
regex = re.compile(r"^[a-zA-Z0-9]{5,15}(?:,[a-zA-Z0-9]{5,15})*$", flags=re.MULTILINE)
test_str = ("3OMYJF5V11MJL,3OMYJF5V11MOP\n"
"3OMYJF,3OMYJim,3OMYJF090")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")