using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"session\(\{\s*secret\:\s*(""|')\w*(""|')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)";
string input = @"session({
secret: ""asdfadf"",
resave: false,
saveUninitialized: false,
})";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}