import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "session\\(\\{\\s*secret\\:\\s*(\"|')\\w*(\"|')\\s*,\\s*resave\\s*\\:\\s*false\\,\\s*saveUninitialized\\:\\s*false\\,?\\s*\\}\\)";
final String string = "session({\n"
+ " secret: \"asdfadf\",\n"
+ " resave: false,\n"
+ " saveUninitialized: false,\n"
+ "})";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}