import re
regex = re.compile(r"session\(\{\s*secret\:\s*(\"|')\w*(\"|')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)", flags=re.MULTILINE)
test_str = ("session({\n"
" secret: \"asdfadf\",\n"
" resave: false,\n"
" saveUninitialized: false,\n"
"})")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")