$re = '/session\(\{\s*secret\:\s*("|\')\w*("|\')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)/m';
$str = 'session({
secret: "asdfadf",
resave: false,
saveUninitialized: false,
})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);