package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)session\(\{\s*secret\:\s*("|')\w*("|')\s*,\s*resave\s*\:\s*false\,\s*saveUninitialized\:\s*false\,?\s*\}\)`)
var str = `session({
secret: "asdfadf",
resave: false,
saveUninitialized: false,
})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}