# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{2})(\d{2})(\d{2})/$1.$2.$3/gm;t' <<< "2013-05-01 120125.jpg
2013-05-01 120126.jpg
2013-05-01 120127.jpg"