import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{2})(\\d{2})(\\d{2})";
final String string = "2013-05-01 120125.jpg\n"
+ "2013-05-01 120126.jpg\n"
+ "2013-05-01 120127.jpg";
final String subst = "$1.$2.$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}