// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{2})(\d{2})(\d{2})").unwrap();
let string = "2013-05-01 120125.jpg
2013-05-01 120126.jpg
2013-05-01 120127.jpg";
let substitution = "$1.$2.$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}