const regex = /(\d{2})(\d{2})(\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})(\\d{2})(\\d{2})', 'gm')
const str = `2013-05-01 120125.jpg
2013-05-01 120126.jpg
2013-05-01 120127.jpg`;
const subst = `$1.$2.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);