re = /(\d{2})(\d{2})(\d{2})/m
str = '2013-05-01 120125.jpg
2013-05-01 120126.jpg
2013-05-01 120127.jpg'
subst = '$1.$2.$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result