use strict;
my $str = '2013-05-01 120125.jpg
2013-05-01 120126.jpg
2013-05-01 120127.jpg';
my $regex = qr/(\d{2})(\d{2})(\d{2})/mp;
my $subst = '$1.$2.$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";