#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{2})(\d{2})(\d{2})"
Local $sString = "2013-05-01 120125.jpg" & @CRLF & _
"2013-05-01 120126.jpg" & @CRLF & _
"2013-05-01 120127.jpg"
Local $sSubst = "$1.$2.$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)