using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<in>|\s+.*?(?=\b\w+<in>)";
string substitution = @"\n";
string input = @"application<in>rid and test<in>efd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}