const regex = /<in>|\s+.*?(?=\b\w+<in>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<in>|\\s+.*?(?=\\b\\w+<in>)', 'g')
const str = `application<in>rid and test<in>efd`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);