import re
regex = re.compile(r"<in>|\s+.*?(?=\b\w+<in>)")
test_str = "application<in>rid and test<in>efd"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)