using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>(*SKIP)(*F)|blue";
string input = @"dont match here <span class=""blue"" title=""This is blue!"">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}