const regex = /<[^>]*>(*SKIP)(*F)|blue/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>(*SKIP)(*F)|blue', 'g')
const str = `dont match here <span class="blue" title="This is blue!">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}