re = /<[^>]*>(*SKIP)(*F)|blue/
str = 'dont match here <span class="blue" title="This is blue!">Aqua</span>
match ablue here
okay here too <a stuff>match blue here</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end